July 18, 2018
Register | Login
Web Site Requirements

Although most of the Electronic Bulletin and Planroom can be viewed with Internet Explorer, a few plug-ins are required to view plans, specs and addenda. This page contains information about what programs must be installed and how to install them. We recommend that you print out the instructions for each step before beginning the process.

  • Internet Explorer is the first requirement. Chances are, you already have Internet Explorer installed on your computer. If you do not have this installed, click the link and follow the instructions to install.
  • After installing Internet Explorer, install Adobe Acrobat Reader to view specs and addenda.
  • After installing Internet Explorer, install FastBid Reader to view plans.

After installing these programs, you should be ready to use the PBE Electronic Bulletin and Planroom.

  Minimize